Le forum espace client

Rechercher

information

Une nouvelle offre depuis le 14 novembre pour les abonnés Qu'en pensez-vous ?

Légende :

  • à consulter
  • approuvé

COMMUNAUTE D'ENTRAIDE CANAL

Communauté d'entraide canal

Communauté d'entraide canal

Numéro client :
Mon mode de réception :

Déconnexion

Sujet en attente de participation

Live TV MyCanal - Erreur 6030 depuis peu ???

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Bonjour,

Je me suis rendu compte depuis quelques jours qu'un problème m'empeche de regarder le Live TV de MyCanal sur mon PC (il fonctionne très bien sur mon smartphone et sur un autre ordinateur avec mes identifiants. Canal+ à la demande fonctionne très bien également sur mon PC).

Je rencontre des messages d'erreurs, notamment l'erreur 6030: "Impossible d'obtenir la licence de ce programme. Vérifier que vos pilotes de carte graphique sont à jour et redémarrer le lecteur."
J'ai également eu le message d'erreur comme quoi "ce service n'était disponible qu'en France" (je l'ai eu hier soir et je n'ai pas relevé le numéro exact de l'erreur), pourtant je n'utilise pas de proxy.

Ce que je ne comprends pas c'est que le LiveTv fonctionnait très bien sur mon PC depuis plusieurs mois...et d'un coup il ne fonctionne plus alors que je n'ai apporté aucune modification à ma configuration entre temps (à part la mise à jour de mes drivers).

Mon navigateur est Firefox 35.0.1 (donc dernière version officielle en date), je n'ai pas de proxy configuré dedans (ni meme ailleurs dans d'autres logiciels).
Mes drivers de carte graphique ont été désinstallés/réinstallés plusieurs fois pour faire des tests, avec entre temps reboot du PC et nettoyage avec CCleaner. Ils sont bien à jour (une nouvelle version des drivers Nvidia est meme sortie hier: GeForce 347.52, je l'ai donc installé et testé mais j'ai toujours le message d'erreur...).
Je conclue donc que mon problème ne vient pas de mes drivers graphique contrairement à ce qu'indique le message d'erreur, ni de mon materiel (je n'ai aucun problème dans mes jeux et autres...).

J'ai également testé le LiveTV sur Internet Explorer 11 mais j'ai toujours le meme message d'erreur...
J'ai Silverlight en version 5.1.30514.0 et il fonctionne très bien sur d'autres sites (par exemple, validé sur ce test: http://bubblemark.com/silverlight2.html ).

Ma configuration est la suivante (à noté qu'absolument tout mes drivers sont à jour et que je n'en ai pas d'installé en version beta):
Carte mère MSI Z97 GAMING 5
Processeur Intel Core i7 4790K
RAM Corsair Dominator Platinum 2 x 4 Go DDR3 PC12800 CAS 8
Carte graphique Asus GeForce GTX 970 STRIX OC - 4 Go
Stockage 1 Samsung Serie 850 Pro - 256 Go + 2 Western Digital WD Green 3,5" - SATA III 6 Gb/s - 1 To (Caviar)
Système d'exploitation: Windows 8.1 Professionnel (licence officielle)
FAI testés: Orange et Free

Merci pour vos futures réponses et votre aide.

Participations

fsquinquin
fsquinquin

fsquinquin

sujets postés
0
participation
1
Niveau
0
10 / 100
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Bonjour,
J'ai eu le même problème mais après réflexion je me suis rendu compte que ce dernier est apparu après une extension d'écran sur un videoproj pour le boulot. J'ai donc remis mon écran d'ordi et ca marche!!!!
Cordialement.

pierrickand
pierrickand

pierrickand

sujets postés
7
participations
12382
Niveau
6
160521 / 500000
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

rasoc a écrit :

Bonjour,
J'ai aussi rencontré le problème de l'erreur 6030 (alors que ca fonctionnait tres bien avant).
J'ai tout tenté sans résultat (Maj driver graphique, Maj Silverlight, test sur Internet explorer, Firefox, suppression du fichier Mspr.hds et son cache...) Bref j'ai tout fait sauf.... passer sur Google chrome !
j'ai installé Google chrome + réinstall de sylverlight (Obligatoire car demandé lors de l'install) et depuis ca marche Nickel !!! j'e diffuse MyCanal sur ma TV sans aucun problème.
Merci tonton GOOGLE !

Bonsoir,

pour info avec Chrome, Silverlight n'est plus compatible, donc c'est étonnant que vous ayez eu une demande de l'installer (sauf si vous avez essayé de télécharger à la demande, dans ce cas, ce n'est pas possible avec Chrome car il faut obligatoirement Silverlight).

rasoc
rasoc

rasoc

sujets postés
0
participation
1
Niveau
0
12 / 100
points
Custom field 2
TNT
Custom field 3
Custom field 4
Custom field 7

Bonjour,
J'ai aussi rencontré le problème de l'erreur 6030 (alors que ca fonctionnait tres bien avant).
J'ai tout tenté sans résultat (Maj driver graphique, Maj Silverlight, test sur Internet explorer, Firefox, suppression du fichier Mspr.hds et son cache...) Bref j'ai tout fait sauf.... passer sur Google chrome !
j'ai installé Google chrome + réinstall de sylverlight (Obligatoire car demandé lors de l'install) et depuis ca marche Nickel !!! j'e diffuse MyCanal sur ma TV sans aucun problème.
Merci tonton GOOGLE !

elleoj65
elleoj65

elleoj65

sujets postés
0
participations
2
Niveau
0
21 / 100
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Lilou - Equipe CANAL a écrit :

Bonsoir Domi73,

Merci de votre retour rapide.

Il faut absolument supprimer le fichier caché mspr.hds et non le renommer. 

Pouvez-vous faire le nécessaire en suivant les indications d'Antoine et nous tenir informés ?

Important : une fois le fichier supprimé, je vous invite aussi à vider votre corbeille.

Merci beaucoup, je reste disponible.

Lilou

c'estfait j'ai suivi toutes les procédures et maintenant plus rien du tout même dans canalplay my canal etc encore heureux que je puisse accéder à l'ebtraide je suis furieuse merci

 

edanwan
edanwan

edanwan

sujets postés
0
participation
1
Niveau
0
10 / 100
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Bonjour, je viens d'avoir le soucis.
Celui-ci s'es produit après rebranchement complet de mon pc suite à cun changement de pâte thermique.

Pour faire rapide, sur un port DVI de ma carte vidéo (ellle en a deux) mycanal fonctionne et pas sur l'autre.

Les droits DRM ne passent pas par la deuxième sortie vidéo.

Si çà peut aider.

Cordialement

Lilou - Equipe CANAL
Lilou - Equipe CANAL

Lilou - Equipe CANAL

sujets postés
124
participations
3612
Niveau
5
34677 / 50000
points
Equipe

Suivez @InfoAbonneCanal. Notre compte officiel sur Twitter !

Custom field 2
Custom field 3
Custom field 4
Custom field 7

Bonjour Domi73,

Merci de votre retour rapide. 

Je suis navrée que les manipulations proposées n'aient pas solutionné le dysfonctionnement.

Je vous conseille de bénéficier d'un diagnostic pas à pas avec un technicien via le Chat myCanal. 

N'hésitez pas à nous tenir informés sur ce fil de discussion.

A très vite

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Bonsoir,

Je viens de supprimer le dossier C:/ProgramData/Microsoft/Playready et vidé la Corbeille, redémarré mon PC mais j'ai toujours le meme message d'erreur...sauf que le numéro du message d'erreur n'est plus 6030, mais 6000 maintenant...et je n'ai pas de dossier Playready qui s'est recréé...

Je vais réinstaller Silverlight pour tester je pense...

Edit: Je viens de désinstallé/réinstaller Silverlight (j'ai désinstallé l'appli à l'aide de Revo Uninstaller Pro afin de ne laisser aucune trace sur le PC, j'ai redémarré ma machine, nettoyé avec CCleaner (pour etre sur qu'il ne reste aucun résidu) puis essayé d'installé Silverlight en 32 bits car mon navigateur est en x86 = no ok, puis je l'ai installé en 64bits (à noter que mon système d'exploitation est en x64) et après avoir lancé MyCanal et selectionné la chaine que je souhaite regarder j'ai de nouveau le message d'erreur avec le numéro 6030...

Je pense que le problème ne vient pas de là car je ne vois pas se que je peux faire de plus...et l'appli MyCanal sur Windows ne fonctionne pas non plus...

Lilou - Equipe CANAL
Lilou - Equipe CANAL

Lilou - Equipe CANAL

sujets postés
124
participations
3612
Niveau
5
34677 / 50000
points
Equipe

Suivez @InfoAbonneCanal. Notre compte officiel sur Twitter !

Custom field 2
Custom field 3
Custom field 4
Custom field 7

Bonsoir Domi73,

Merci de votre retour rapide.

Il faut absolument supprimer le fichier caché mspr.hds et non le renommer. 

Pouvez-vous faire le nécessaire en suivant les indications d'Antoine et nous tenir informés ?

Important : une fois le fichier supprimé, je vous invite aussi à vider votre corbeille.

Merci beaucoup, je reste disponible.

Lilou

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Bonjour,

Je viens de tester votre solution: j'ai renommé le fichier mspr.hds en .old. Un nouveau fichier s'est bien créé lorsque j'ai relancé le LiveTV mais malheureusement j'ai toujours le meme message d'erreur...Faut-il supprimer le dossier en entier?

Du coup j'ai tenté une réinstallation totale de Silverlight, mais le résultat est toujours le meme: j'ai toujours ce message d'erreur.

J'ai réessayé l'appli MyCanal du Windows Store mais idem...

Avez-vous d'autres solutions à tester svp car je commence à perdre espoir?...

Antoine - Equipe CANAL
Antoine - Equipe CANAL

Antoine - Equipe CANAL

sujets postés
54
participations
2837
Niveau
5
35270 / 50000
points
Equipe

Suivez @InfoAbonneCanal. Notre compte officiel sur Twitter !

Custom field 2
Custom field 3
Custom field 4
Custom field 7

Bonjour domi73,

Tout d'abord merci à pierrickland pour son aide. 

L'erreur 6030 est dû à la corruption du fichier Playready (Silverlight). 

Cette erreur devrait disparaître si vous supprimez le fichier caché mspr.hds.

Voici la marche à suivre pour les utilsateurs de Windows 8.1 :

  1. Ouvrez une fenêtre d'explorateur Windows
  2. Ouvrez l'onglet Affichage
  3. Cliquez sur le bouton Options
  4. Ouvrez l'onglet Affichage
  5. Sélectionnez l'option Afficher les fichiers, dossiers et lecteurs cachés.
  6. Allez ensuite dans le dossier C:/ProgramData/Microsoft/Playready
  7. Supprimez le dossier cache et le fichier mspr.hds

Je reste à votre disposition. 

Tenez moi informé. 

A bientôt,

pierrickand
pierrickand

pierrickand

sujets postés
7
participations
12382
Niveau
6
160521 / 500000
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Bonjour,

Ba je ne sais pas trop. Il y a quelques chose qui a dû se modifier (peut être suite à une mise à jour).

Vous pouvez tenter de desinstaller silverlight puis de le réinstaller depuis le site de microsoft. Testez également l'appli MyCanal avant de le réinstaller, il n'est pas utile pour cette appli.

Sinon, essayez de poser la question sur la communauté microsoft, ils auront peut être une idée.

Désactiver le HDCP n'est pas possible.

Cdt

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Bonjour,

Je viens d'essayer et les essais ne sont pas concluant (je pense que le problème ne vient pas de là).

J'ai essayé, dans l'ordre, avec extinction de l'ordinateur entre chaque modification des branchements:
Débrancher l'HDMI derrière ma carte graphique (du coup plus de barre de son ni de télé, uniquement l'écran HP) = Meme message d'erreur.

Débrancher adaptateur DVI/VGA derrière ma carte graphique + rebrancher l'HDMI (j'ai donc la barre de son et la télé mais plus l'écran HP) = meme message d'erreur

Débrancher l'HDMI dérrière ma barre de son pour la brancher directement derrière ma télé (j'ai donc uniquement la télé branchée en direct avec ma CG via le port HDMI) = meme message d'erreur...

La seule chose que je n'ai pas essayé c'est avec un autre cable HDMI (je n'en ai pas d'assez long donc ça m'oblige à déplacer la télé et je n'ai pas trop le temps ce matin, peut etre dans le week-end mais je ne suis pas sur que le résultat soit meilleur sachant que c'est un cable de marque avec les connecteurs en or).


Pour rappel, les branchements qui fonctionnaient lorsque je pouvais encore regarder le LiveTV:
Sur mon écran HP + sur ma télé lorsqu'elle était branchée en direct sur ma carte graphique via le port HDMI.

Pour etre honnete je commence à perdre un peu espoir là...et je n'ai pas franchement envie de formater mon PC uniquement pour ça...

Je peux tenter une réinstallation de Silverlight?
Ou existe-t-il un paramètre pour retirer la protection HDCP quelque part afin d'oter tout les doutes concernant cet aspect?

Encore une fois merci pour votre aide.

pierrickand
pierrickand

pierrickand

sujets postés
7
participations
12382
Niveau
6
160521 / 500000
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Oui ça peut venir de là.

 

En fait c'est la protection HDCP (qui est gérée par la carte graphique sur la prise HDMI) qui doit poser problème. La protection HDCP doit garantir que la vidéo sera lu sur un écran sans possibilité d'être intercepté en chemin. Avec vos nouveaux branchements, la carte graphique ne doit pas réussir à le garantir et donc cette protection bloque la vidéo.

 

Pour en être sûr essayez uniquement avec l'écran HP.

Puis essayez uniquement avec la TV en HDMI sur le PC.

Si ça ne marche pas avec l'écran HP mais que ça marche avec la TV, c'est que le problème vient de l'adaptateur DVI/VGA.

Si ça ne marche pas avec la TV mais que ça marche avec l'écran HP, c'est que le problème vient d'une mauvaise communication entre la carte graphique et la TV (peux être essayer un autre câble HDMI?)

Si ça ne marche pas dans les 2 cas, essayez votre ancien écran (si vous l'avez toujours). Si ça ne marche toujours pas, c'est que le problème est ailleurs sur le PC (peut être une mise à jour windows ayant posée problème?).

 

Si ça marche avec les 2 indépendamment, essayez alors de brancher les 2 (toujours sans la barre) de son.

Si ça ne marche pas, c'est que la carte graphique n'arrive pas à garantir la protection HDCP avec les 2 écrans ensemble. Du coup, essayez différentes combinaisons de double-écran (inversez l'écran principale et secondaire, mode dupliqué, mode étendu, etc...)

Si ça marche, c'est que le problème vient du passage dans la barre de son.

 

Tenez moi informé des différentes combinaisons qui marchent ou pas afin de réfléchir à une solution.

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Merci pour vos explications, mais d'où pourrait provenir ce problème de gestion des DRM (je n'y connais rien là dessus)?

Car comme indiqué, à part mettre à jour mes drivers je n'ai rien fais de spécial entre le moment où ça fonctionnait et le moment où j'ai eu le message d'erreur.

Pour etre plus clair: je me suis offert cette config' "pour Noel", je l'ai donc montée/installée début décembre. Après avoir installé et configuré mes logiciels, j'ai utilisé MyCanal. J'ai regardé plusieurs films et matchs, donc mi-décembre ça fonctionnait.

Je me suis rendu compte début Février que MyCanal ne fonctionnait plus, avec le message d'erreur indiqué. MyCanal a donc fonctionné environ 1 mois et demi correctement.
Au moment où je me suis rendu compte du message d'erreur j'avais encore l'avant dernière version des drivers NVidia installée sur mon poste.
Pensant que c'était un problème de driver j'ai essayé de les réinstaller comme indiqué dans mon premier post, mais le LiveTV ne fonctionnait toujours pas. Il y a 2 jours, une nouvelle version des drivers NVidia est sortie, j'ai donc sauté sur l'occasion pour les mettre à jour pensant que mon problème serait résolu, mais ce n'est pas le cas (je possède donc maintenant les derniers drivers NVidia).

Oui j'ai 2 écrans, et maintenant que vous m'y faite penser ma config à changé de ce coté:
Avant j'avais:
1-Mon écran de PC (un vieux HP avec une résolution de 1680x1050) relié à ma carte graphique par un cable VGA
2-Une télé (Brandt B3220HDLED avec une résolution de 1920x1080) relié à ma carte graphique par un cable HDMI
Début Février j'ai acheté une barre de son LG et ma configuration est désormais comme ça:
1-Mon écran HP relié à ma carte graphique par un cable VGA (un adaptateur DVI/VGA est placé derrière ma carte graphique)
2-Ma télé (Brandt B3220HDLED) reliée à la barre de son LG LAB540 sur le port HDMI Out et cette barre de son est reliée à la carte graphique de mon PC par un cable HDMI via le port IN.

Mes problèmes pourraient venir de là?

pierrickand
pierrickand

pierrickand

sujets postés
7
participations
12382
Niveau
6
160521 / 500000
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

SI vous avez aussi un message similaire sur l'appli MyCanal, c'est qu'il y a un problème de gestion des DRM sur votre PC qui impacte à la fois Silverlight et les applis du windows store.

Par contre j'ai un peu de mal à vous suivre, vous dites "Cela ne fonctionnait déjà pas avant" puis "MyCanal via mon navigateur fonctionnait très bien avant".

Çà marchait ou ça ne marchait pas?

Sinon, avez-vous 2 écrans?

cdt

domi73
domi73

domi73

sujet posté
1
participations
5
Niveau
0
56 / 100
points
Custom field 2
ADSL Free
Custom field 3
Custom field 4
Custom field 7

Bonjour,


Merci pour cette réponse.
Malheureusement je rencontre toujours le problème...que ce soit via mon navigateur internet ou sur l'application MyCanal du Windows Store (je viens de l'installer et j'ai exactement la meme erreur sur le LiveTV.)

Juste une précision: Cela ne fonctionnait déjà pas avant que je mette mes drivers graphique à jour (j'ai donc testé, au moins avant que je me rende compte qu'il y avait un problème, 2 versions de mes drivers graphique).

Ayant exactement le meme message d'erreur sur l'appli MyCanal, je peux donc éccater le fait que c'est un problème Silverlight.
Ce qui m'arrange car je ne comprends pas comment fonctionne votre testEmbarrassé (je l'ai testé sur un autre PC sur lequel le LiveTV fonctionne et je n'y arrive pas non plus, lol).


Donc en résumé:

MyCanal via mon navigateur fonctionnait très bien avant, les seuls modifications que j'ai faites sont mettre à jour mes drivers. Mon problème ne semble pas venir de mes drivers de carte graphique car j'ai essayé avec 2 versions différentes et mon problème ne vient apparement pas de Silverlight...je suis donc perdu...merci de m'aider car je ne sais pas de quel coté chercher et j'aimerais bien que le LiveTV refonctionne pour la reprise de la Champion's League Rigolant

pierrickand
pierrickand

pierrickand

sujets postés
7
participations
12382
Niveau
6
160521 / 500000
points
Custom field 2
SAT
Custom field 3
Custom field 4
Custom field 7

Bonjour,

Pour tester Silverlight, il faut mieux utiliser ce site http://web.sldrm.video.msn.com/d1/sldrm.html

L'erreur 6030 est généralement lié à un problème sur la prise en charge des DRM et la protection HDCP par la carte graphique.
Si ce test ne marche pas, c'est qu'il y a bien un problème avec SIlverlight sur votre PC.

Vu que vous avez mis à jour vos driver avant que ça ne marche plus, il se peut que la dernière version des pilotes GeForce pose problème. Essayez en repassant sur la version d'avant.

Sinon, vu que vous êtes sur Win8.1, il y a une autre solution pour ne plus avoir de problème avec Silverlight, c'est d'utiliser l'appli MyCanal disponible dans le Windows Store. Celle-ci fonctionne sans Silverlight.

cdt